Wednesday, November 10, 2010

Bootstrapper package for Windows Imaging Component

Developers who target .NET 4 and choose to create a proper bootstrapper for their installer have been bit repeatedly by installation failures on Windows XP SP2 and Windows Server 2003. .NET 4 fails to install on these admittedly outdated, but still widespread OSes because it depends on the Windows Imaging Component, which appears in XP SP3, Vista, 7 and 2008 Server and is installed with .NET 3.5 SP1. These OSes increasingly being the majority, Microsoft decided to leave WIC out of the .NET 4 installer in order to reduce the download size, a laudable intention. Since they actually documented this, there is no cause to complain; but why not also provide a bootstrapper package for WIC in the Windows SDK since it began to include packages for .NET 4? Developers usually direct the bootstrapper to download Microsoft files from the home site, so setup size would not increase appreciably.
Anyway. I created a WIC bootstrapper package and tested it on XP SP2, XP SP3 and 7. I also added a dependence on WIC to the .NET 4 packages. No warranty; use at own risk but comments welcome!

5 comments:

Miron Ion said...

Hi,

I wanted to look at the WIC bootstrapper package example - but I can't see the right files; I see some diff files.
Can you please help me?

Thanks.

Miron Ion said...

My bad ... I was getting the right files. I just didn't understood it correctly at first glance.

Сергей said...

And I still can't find right files. :( Can you save them as files somewhere, please?

Anton Tykhyy said...

Sergey: zip file here for 30 days; add following line to DotNetFX40Client\product.xml to make .NET 4 dependent on WIC and have the bootstrapper install packages in correct order:
<DependsOnProduct Code="Windows.Imaging.Component" />

Mojtaba Ashena said...

Hi, I appreciate it if you can send the zip file to me

Email: moji6030@yahoo.com

Thanks a lot